• Release date:
    Bluetooth version:
    OS:
    Comment:

    Phonak Marvel compatibility:

    Phone calls & music streaming to both ears

    Phone calls and music streaming were tested and worked with this model.

    This model is compatible for wireless calls and music streaming.

    This model should be compatible for wireless calls and music streaming.

    This model may be compatible for wireless calls and music streaming. It minimally should support Bluetooth version 2.1, optimally 4.2 and higher.

    This model was tested but sometimes showed problems.

    Internal tests have shown that this model is not compatible.

    Based of the available information, this model is not compatible.

    We don't have enough information about this model right now. If it is Bluetooth 2.1 certified (or newer) it should be compatible.

    myPhonak App

    The myPhonak app was tested and worked with this model.

    This model is compatible with the myPhonak app.

    Internal tests have shown that this model is not compatible with the myPhonak app.

    This model was tested but sometimes showed problems with the myPhonak app.

    This model may be compatible with the myPhonak app. While the app is certified for Bluetooth 4.2, some models with 4.0 and 4.1 may work as well.

    Based of the available information, this model is not compatible to the myPhonak app. For the myPhonak app to be compatible, the model must minimally support Bluetooth 4.2, and iOS 10.2 or Android 6.0 (Marshmallow).

    Concerning myPhonak app, we haven't enough information about this model right now. It minimally must support Bluetooth 4.2, and iOS 10.2 or Android 6.0 (Marshmallow).

    Remote App

    The Phonak Remote app was tested and worked with this model.

    This model is compatible with the Phonak Remote app.

    Internal tests have shown that this model is not compatible with the Phonak Remote app.

    This model was tested but sometimes showed problems with the Phonak Remote app.

    This model may be compatible with the Phonak Remote app. While the app is certified for Bluetooth 4.2, some models with 4.0 and 4.1 may work as well.

    Based of the available information, this model is not compatible to the Phonak Remote app. For the Phonak Remote app to be compatible, the model must minimally support Bluetooth 4.2, and iOS 10.2 or Android 6.0 (Marshmallow).

    Concerning Phonak Remote app, we haven't enough information about this model right now. It minimally must support Bluetooth 4.2, and iOS 10.2 or Android 6.0 (Marshmallow).

    The compatibility information should be used as a reference guide only, because hardware and software levels and releases may vary, and numerous hardware and software combinations are possible. Phonak assumes no responsibility for the compatibility thus it is the user's responsibility to do product compatibility testing by himself before any purchasing decision is taken.